Bug report #896

Quickprint Plugin scaling issues

Added by John Tull almost 13 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:10955

Description

In Quickprint plugin on OS X, 0.9.2 from trunk, scaling problems are apparent with the legend, title and map. Possibly dpi is not actually at default 300. Text in legend and legend symbols are quite tiny. Title text is quite large.

test.pdf - OS X test Quick Print plugin, 30 Oct 2008 build (150 KB) John Tull, 2008-11-01 09:55 AM

History

#1 Updated by mesajs - about 12 years ago

Quickprint on Windows Vista 64 bit: Labels on map features are way to large. e.g. set font to Arial 10 points, but lettering on printed map is over 5mm high, obliterating map. Not so much a problem if font size is set to map units.

Applies to versions 0.11.0-1 and 0.11.0-2

#2 Updated by Marco Hugentobler almost 12 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

I think this is fixed with the latest changes in Quickprint. Feel free to reopen the bug if not.

#3 Updated by John Tull almost 12 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

The fonts appear good. I ran a test print to a large format (B1) and it worked well. The qgis logo, scalebar, and north arrow are disproportionately large compared to the rest. I've attached the example to the ticket. Is this still a scaling issue?

#4 Updated by Giovanni Manghi over 11 years ago

Made the same test on QGis 1.2 on both Linux and Windows, and the problem is replicable.

On Windows text is even smaller than on linux.

Here is a link were you can downloads two pdf obtained with the same data, in B1 format, with the same font (type and size), on Linux and Windows.

See attached files.

Pushing the milestone to 1.2.

#5 Updated by Giovanni Manghi over 11 years ago

Attachments too big, download it here:

http://www.faunalia.pt/downloads/quick_print_test.tar.gz

#6 Updated by Paolo Cavallini over 10 years ago

Still true?

#7 Updated by John Tull over 10 years ago

Text appears to be better for me. The qgis icon is quite large, as in the original sample file I attached.

#8 Updated by Paolo Cavallini about 10 years ago

Please note taht QuickPrint plugin will probably be removed from future versions of QGIS, as better options are available.

#9 Updated by Paolo Cavallini over 9 years ago

Would 1.7 release the right time to remove QuickPrint and close this bug?

#10 Updated by John Tull over 9 years ago

I'm happy to see this changed to wontfix if so.

#11 Updated by Tim Sutton over 9 years ago

  • Status changed from Feedback to Closed
  • Resolution set to wontfix

I've removed this plugin with f6c16778 (SVN r15314). Users wanting similar functionality should use the QuickPrint plugin rather.

Thanks

Tim

#12 Updated by Tim Sutton over 9 years ago

Replying to [comment:12 timlinux]:

I've removed this plugin with f6c16778 (SVN r15314). Users wanting similar functionality should use the QuickPrint plugin rather.

Thanks

Tim

Correction I meant to say "Users wanting similar functionality should use the EasyPrint plugin rather."

Also available in: Atom PDF