Bug report #8927

Expression labeling not working

Added by Matthias Kuhn about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17599

Description

How to reproduce:
As reported by @macho: Open a spatialite layer and label the features with a field other than the id. The field text is not printed.

Problem:
The problem is, that at qgsvectorlayer.cpp:701 a subset of attributes to be fetched from the provider is specified. This is queried from the renderer, but it seems, that the renderers (at least some of them) only report the attributes used for their symbol rendering + rotation + scaling, but not the attributes used in the labeling expression.

@dakcarto: I assigned this to you because I think you are the labeling guy. Please reassign if you feel somebody else fits better ;)


Related issues

Related to QGIS Application - Bug report #8888: labelling fails for splite spatial views Closed 2013-10-17

History

#1 Updated by Matthias Kuhn about 6 years ago

  • Assignee deleted (Larry Shaffer)
  • Status changed from Open to Closed

Fixed in fa90fc9

Thanks jef for proofing me wrong ;)

Also available in: Atom PDF