Bug report #8881

QGIS server fails to display capabilities when there are 2 layers of the same postgis table

Added by Augustin Roche about 7 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:17561

Description

When the project contains several layers based on the same postgis table (possibly with different sql filters), the GetCapabilities request takes forever and ends with timeout.
Tested on Windows with Apache, fcgi.

History

#1 Updated by Alessandro Pasotti almost 7 years ago

Tested today on master: I cannot reproduce.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Please test with a recent QGIS release (2.18 or 3), if the issue/request is still valid change the affected version accordingly, if is fixed/implemented then close the ticket. Thanks!

#4 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Description updated (diff)
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF