Bug report #8750

Vectors draws partially in some scales, not at all in others...

Added by Klas Karlsson almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17461

Description

Tested with several shapefiles. In small scale it seams to work fine, but as I zoom in the data disappears partially (geographic not screen position) and eventually disappears completely.
(see attached screen capture)
When panning, hidden data may reappear and visible data disappear. There are some form of pattern to it but I haven't been able to identify it.

It may be related to a plug-in, but I can not eliminate the error by un-installing all of them, and when I try on a clean 13.04 Ubuntu it works fine but on my 12.04 not so much (have not tested on other platforms).

Raster data works fine but vectors don't (second image). I've only tested with *.shp and *.gpx.

I've tried with different projections and more or less all I can think of. If you suggest it I will try complete un-install and start over.

The problem started when updating to Dufour.

When I find the time I'll try it on other OS as well, and right now I'm not convinced it actually is a "Bug", but it certainly is annoying.

09.png - Screen Cap of missing data. (971 KB) Klas Karlsson, 2013-10-02 11:17 AM

38.png - Screen Cap of raster+vector (1.6 MB) Klas Karlsson, 2013-10-02 11:17 AM

53.png (506 KB) Klas Karlsson, 2013-10-05 06:59 AM

History

#1 Updated by Klas Karlsson almost 7 years ago

When data is missing it is only in the top and/or right part of the map window. Never bottom or left!

#2 Updated by Jukka Rahkonen almost 7 years ago

For eliminating one possibility I would delete and recreate the .qix index. However, I do not really believe it will help because you are also having troubles with .gpx.

#3 Updated by Klas Karlsson almost 7 years ago

Nope! Tried deleting the index file and rebuilding it, no luck!
Most files do not have a .gix file anyway but I've tried building them, removing and re-building...

#4 Updated by Klas Karlsson almost 7 years ago

I just made a complete uninstall, tried to removed all qgis related files and folders, re-booted and tried a fresh QGIS install.

It didn't help. Same problem.

#5 Updated by Klas Karlsson almost 7 years ago

Found a pattern!

Data is cut at whole degree intervals...

Only data that are less than the degree part of the coordinate at the top right corner are displayed.
If (in my case) the coordinate 16 deg East and 58 deg North lies just outside top right corner, no data located north or east of 15 East and 57 North are displayed.

Attached image screen dump.

#6 Updated by Klas Karlsson almost 7 years ago

  • Status changed from Open to Closed

Not sure if this was the actual fix, but...

When trying to add the QGIS-grass-plugin I ran into problems. Removing and re-installing grass (apt-get purge grass / apt-get install grass) worked for that, and...

Vector data started to act as it should do!

From my point of view the issue is "closed".

Also available in: Atom PDF