Bug report #867

Buidling DBMS support for Grass and GDAL (Tishampati Dhar)

Added by leo-lami - over 12 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10926

Description

The dbf driver doesn't work if I work with GRASS vector.
This a collect of mail on the arguments:

I can confirm the dbf problem in QGIS/GRASS. I am running QGIS 0.9.0
26.10.2007 build. My OS is Vista but I don't think it matters. I am also
running WINGRASS 6.3RC3 and I got the same problem so something is broken in
winGRASS now. See the error messages for more info. The messages are from
the CLI from within QGIS

$ db.connect -p
driver:dbf
database:$GISDBASE/$LOCATION_NAME/$MAPSET/dbf/
schema:
group:
The connection set up looks fine to me, but if you try getting info in a
specific layer:
$ v.db.connect map=dist2_net3 -c
Invalid argument: can't _spawnl
GRASS_INFO_ERROR(260,1): Unable to start driver <dbf>
GRASS_INFO_END(260,1)

If I try db.describe from winGRASS I get this: {database=$GISDBASE/$LOCATION_NAME/$MAPSET/dbf/}
invalid argument: can't _spawnl

Unable to start driver <dbf>

Benjamin wrote:
There are many little annoyances with the GDAL linking.
But they can all be rectified (at least I managed for
version 1.4.4, don't know about 1.5 yet).

I think I left out that final bit in my last email.

Here it is.
For 1.5, you will probably need to update the last bit
somewhat, since I think all user tools are now in the
"apps" subfolder.

Let me know how it's working for you.

History

#1 Updated by Paolo Cavallini over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Presumably solved in the latest versions of the installer. Reopen it if appropriate.

#2 Updated by Anonymous almost 11 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF