Bug report #8665

QGIS doesn't use SID for Oracle connection

Added by Jonathan Moules almost 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17394

Description

The oracle connection help says:

"Database" - SID or SERVICE_NAME of the Oracle instance.

However, if I enter a valid SID of a database here, it will fail with a ORA-12514 error. I spent many hours of frustration wondering why my Oracle connection wasn't working due to this. :-(
It does work if a SERVICE_NAME or GLOBAL_NAME is entered.


Related issues

Duplicates QGIS Application - Bug report #8648: QGIS Oracle connection Closed 2013-09-23

History

#1 Updated by Jürgen Fischer almost 7 years ago

Do you specify only the SID and no host? SIDs are not required to be unique across hosts - so I suppose specifying only a SID only works, if the database instance runs locally (and listens on port 1521).

#2 Updated by Jonathan Moules almost 7 years ago

My Oracle isn't on localhost.

Leaving the Host or Host-and-Port blank while filling in the SID results in an ORA-12154 error.

#3 Updated by Jürgen Fischer almost 7 years ago

Jonathan Moules wrote:

My Oracle isn't on localhost.

Leaving the Host or Host-and-Port blank while filling in the SID results in an ORA-12154 error.

I'd say that's nothing unusual.

#4 Updated by Jonathan Moules almost 7 years ago

I actually have that as a feature request in #8666


Back on topic - the bug is that using SID (with a host and port) doesn't work even though it apparently should (so the docs say).

#5 Updated by Jürgen Fischer almost 7 years ago

Jonathan Moules wrote:

Back on topic - the bug is that using SID (with a host and port) doesn't work even though it apparently should (so the docs say).

Specifying a SID (in the database row) and host works for me (with a 10g database).

#6 Updated by Jonathan Moules almost 7 years ago

Using Oracle 10g here (though with the 11 client).

The TNSnames entry looks like this:
co_gistest.world =
(DESCRIPTION =
(ADDRESS =
(COMMUNITY = wcctcp.world)
(PROTOCOL = TCP)
(Host = co-gistest-li2)
(Port = 1521)
)
(CONNECT_DATA =
(SID = gistest)
(GLOBAL_NAME = co_gistest.world)
)
)


Specifying "gistest" as my database instantly gets me back the ORA-12154 error.

#7 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF