Bug report #8582

QGis 1.9 d2af494 - Problem loading a style

Added by Nelson Ugalde Araya about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17324

Description

Problem loading a style categorized created earlier.
If you create a style and loads, has the problem that first, that if the column does not exist in the shape to use, is loaded first numeric column that the program finds. One way to correct this is to know the name of the column and change the name directly in the saved style file (. Qml). In my opinion the load a saved style should ask which column should be applied. Another problem is that if you have created a style with custom value ranges, and the column is changed, the ranges are revalued and destroyed, I think you should only happen if there are no defined ranges. Another problem arises if you change the color ramp does not change immediately, but respects the defined ranges, what I do to force change is to change the color ramp, and select a range, until then produces the change in colors


Related issues

Duplicates QGIS Application - Feature request #3775: if column name used for symbology changed, QGIS should as... Open 2015-12-20

History

#1 Updated by Regis Haubourg about 7 years ago

Duplicate of #3775
Can someone raise the priority of #3775? because it comes often in the lists and work around is not ok for non dev's. (manual QML editing)
Régis

#2 Updated by Jürgen Fischer about 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF