Bug report #8450

Selected item not marked blue in attribute window

Added by Lene Fischer almost 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17219

Description

WHen a object is selected with ex. select single feature tool and I open the attritbute window the selected item is not marked blue as normal selected items

Select.swf (1.42 MB) Lene Fischer, 2013-08-11 03:15 PM

History

#1 Updated by Nathan Woodrow almost 7 years ago

Not confirmed here

#2 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Open to Feedback
  • Operating System deleted (Windows and MAC)

I also does not confirm on Linux.

#3 Updated by Lene Fischer almost 7 years ago

#4 Updated by Giovanni Manghi almost 7 years ago

In your case are (light) grey, as in my case (on Windows). It depends on the desktop theme you are using.

#5 Updated by Lene Fischer almost 7 years ago

If I select manually in the attribute window it turns blue as usual. So the difference confuse.

Please see in this link [[http://screencast.com/t/9mb0NpfGh]]

Regards
Lene

#6 Updated by Nathan Woodrow almost 7 years ago

This is because Windows has a different style for Active with Focus and Active without Focus. If you click in the attribute table you are giving it focus so windows colours it blue but if it doesn't have focus it uses the grey colour.

#7 Updated by Lene Fischer almost 7 years ago

But I activate and focus by Move selection to top
Regards
Lene

#8 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

I have tested again on a clean Windows 7 installation, with QGIS master and several desktop themes (the ones shipped with Windows 7) and it always seems to work as expected. Please reopen if necessary.

Also available in: Atom PDF