Bug report #8446

Legend in Print Composer - Layername in default empty symbology class

Added by Lene Fischer almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17215

Description

I have a layer which is categorized. In the layer>legend there is an empty symbology class - as always.
When I insert a legend in the print composer, the empty class now is shown with the layer name - not empty as in the layer legend.

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Subject changed from Legend in Print Composer - Layername in empty signature to Legend in Print Composer - Layername in default empty symbology class

#2 Updated by Giovanni Manghi almost 7 years ago

  • Operating System deleted (Windows and MAC)
  • Priority changed from Normal to Severe/Regression

Confirmed on Linux.

This is a regression since 1.8

In the legend item properties the layername is not associated with the empty class, so it is not possible to just remove the name.

#3 Updated by Nathan Woodrow almost 7 years ago

This is because of:

QString text = symbolItem->text();
if ( text.isEmpty() ) {
// Use layer label, used for single symbols
text = layerItem->text();
}

#4 Updated by Nathan Woodrow almost 7 years ago

I have fixed the bug of using the layer name for anything but single symbols. However there is a side effect of not allowing for blank text. This seems to be a feature of the new legend in 2.0 in order to allow people to reset the label back to the symbol label.

#5 Updated by Nathan Woodrow almost 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF