Bug report #8406

WMTS Connection is not working

Added by Bob Bruce about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Web Services clients/WMS
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17178

Description

I have not been able to get a WMTS server to work with either the stable version of QGIS 1.8.0 or the current development version of 1.9

This is the WMTS connection :

http://nis.cubewerx.com/cubewerx/cubeserv?CONFIG=OIM_MB_-_Orthophoto-WMTS

which is an OGC compliant WMTS server.

(the GetCapabilities request is at: http://nis.cubewerx.com/cubewerx/cubeserv?CONFIG=OIM_MB_-_Orthophoto-WMTS&SERVICE=WMTS&REQUEST=GetCapabilities )

this is part of our NIS pilot project and will be available for another 3 months.

I am able to get this WMTS server to work with OpenLayers though through a web page that I have created. This page is attached to this bug report.

Do you know how QGIS detects that this is a WMTS connection since we are using the WMS connection dialog? I am seeing error messages that keep saying that a WMS connection could not be established, is that because the error message is currently not specific to the type of connection (WMS or WMTS) or because it didn't try and make a WMTS connection?

OpenStreetMap_Example_-_Ortho_Refresh_WMS-WMTS.html Magnifier - A web page with OpenLayer code demonstrating the WMTS connection (5.29 KB) Bob Bruce, 2013-08-02 02:35 PM

History

#1 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Feedback

not reproducable here. Specifying http://nis.cubewerx.com/cubewerx/cubeserv?CONFIG=OIM_MB_-_Orthophoto-WMTS&SERVICE=WMTS&REQUEST=GetCapabilities as URL works fine for me in master.

#2 Updated by Giovanni Manghi about 6 years ago

it works fine here too.

#3 Updated by Jonathan Moules about 6 years ago

#8401 - same thing? I've not tried with that WMTS (my QGIS can't access the internet) but QGIS fails for me on my internal WMTS.

#4 Updated by Jürgen Fischer about 6 years ago

Jonathan Moules wrote:

#8401 - same thing? I've not tried with that WMTS (my QGIS can't access the internet) but QGIS fails for me on my internal WMTS.

Are you also leaving out ?SERVICE=WMTS&REQUEST=GetCapabilies?

#5 Updated by Rémi Bovard about 6 years ago

Jürgen Fischer wrote:

not reproducable here. Specifying http://nis.cubewerx.com/cubewerx/cubeserv?CONFIG=OIM_MB_-_Orthophoto-WMTS&SERVICE=WMTS&REQUEST=GetCapabilities as URL works fine for me in master.

Works fine here too.

#6 Updated by Regis Haubourg about 6 years ago

Hi,
Testing WMTS with authentification leads to crsh here, if authentification fails. Did someone try it?

#7 Updated by Bob Bruce about 6 years ago

Thanks everybody for your help with this.

Today I (finally) managed to get my QGIS master copy updated. I tried this connection with the additional strings &SERVICE=WMTS&Request=GetCapabilities and it worked. So I'm closing this bug report.

Tomorrow I will add a comment to the listserv message to let everyone know that they have to add those strings.

As an additional note: when I get the properties of the layer in QGIS and go to Metadata and go to server properties it shows the label WMS Version rather than WMTS Version.

Bob Bruce

#8 Updated by Bob Bruce about 6 years ago

  • Status changed from Feedback to Closed

I've closed the ticket

#9 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to worksforme

#10 Updated by Jonathan Moules about 6 years ago

I'm not sure this should have been closed.
Consider it from a users perspective - They wouldn't expect to add SERVER and GetCapabilities. Myself I expect QGIS to either:

a) Figure it out automatically.
or
b) Have a separate button for WMTS.

It shouldn't silently fail as it does now. Documenting this limitation won't fix it - you'll still get lots of confused people and posts to the mailing list.
Especially as you don't require those parameters for WMS.

Also available in: Atom PDF