Bug report #8400

crash opening layer properties of a freshly inserted wms layer

Added by Jonathan Moules over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:17172

Description

A repeatable QGIS crash. Windows; weekly a13cdf8

- Add WMS layer.
- Connect
- Select layer
- Add
- Close dialog
- Double click on layer in layers list. Qgis crashes.

The error is an "exception" -> "bad allocation"

I can't find any QGIS log files in my install to give more information.

qgis-20130802-115354-264-4500-a13cdf8.7z (4.11 MB) Jonathan Moules, 2013-08-02 04:41 AM

History

#1 Updated by Salvatore Larosa over 6 years ago

  • Status changed from Open to Feedback

No crashes here by following the above steps. (works fine even on WindowsXP)

#2 Updated by Jonathan Moules over 6 years ago

After further experimentation it seems to only fail with one particular layer (it just happened to be the only layer I actually tested).

I've attached the dump file it creates which I've now found.

#3 Updated by Matthias Kuhn over 6 years ago

Would you be able to share the layer you experience problems with?

#4 Updated by Giovanni Manghi over 6 years ago

also not confirmed here on both linux and Windows, please share the WMS url.

#5 Updated by Giovanni Manghi over 6 years ago

try also disabling all the plugins and try again.

#6 Updated by Jürgen Fischer over 6 years ago

  • Subject changed from Repeatable QGIS crash to crash opening layer properties of a freshly inserted wms layer

#7 Updated by Jonathan Moules over 6 years ago

The WMS is on the internal corporate Network so I can't share it.

Can you not see what the problem is from the dump file?

Any plugins enabled are the default ones. Disabling them makes no difference.

#8 Updated by Jonathan Moules over 6 years ago

Happens with d61cb25 too. It did work once and then it didn't, so it seems to be intermittent.

#9 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to High
  • Target version set to Future Release - High Priority

Still true?

#10 Updated by Jonathan Moules almost 6 years ago

  • Status changed from Feedback to Closed

Seems to be fixed now. (using 5192e8d)
I'll re-open if it happens again.

Also available in: Atom PDF