Bug report #8314

Test suite still used PyQt API v1

Added by Alexander Bruy about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17107

Description

Seems tests still not switched to SIP API v2, see http://dash.orfeo-toolbox.org/testDetails.php?test=17042104&build=123717 and http://dash.orfeo-toolbox.org/testDetails.php?test=18029165&build=123716. Maybe this is the reason why accessing fields by name doesn't work in tests.

Associated revisions

Revision 51074d7b
Added by Jürgen Fischer about 6 years ago

test fixes:
  • port python test to sip api v2 (fixes #8314)
  • introduce compareWkt for more tolerant WKT comparisions in C++ tests
  • require UTF-8 locale for regression1141 test on linux

History

#1 Updated by Jürgen Fischer about 6 years ago

  • Assignee set to Nathan Woodrow

#2 Updated by Jürgen Fischer about 6 years ago

  • Assignee changed from Nathan Woodrow to Jürgen Fischer

#3 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF