Bug report #8237

Georeferencer:Japanese file name problem

Added by KOSUKE ASAHI about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17049

Description

Could I report GDAL georeferencer problem here?

Error occurs, when we use Japanese file name to output file name.
There are two kind behavior.
- file name characters were garbled when we use Japanese characters file name
- don't get any output when file path include Japanese characters

Tested QGIS d37e03b from OSGeo4W.

History

#1 Updated by Minoru Akagi about 6 years ago

  • Target version changed from Future Release - High Priority to Version 2.0.0

There is a pull request to fix this issue: https://github.com/qgis/Quantum-GIS/pull/581

#2 Updated by Hiroyuki Kobayashi about 6 years ago

This problem is the same as I reported to the GDAL site before.
http://trac.osgeo.org/gdal/ticket/4376

It has not been fixed for one and a half year.

I am not sure it is GDAL's issue or QGIS's issue, but I hope it will be fixed as soon as possible, otherwise some potential Japanese (Korean, Chinese..) users would give up to use QGIS.

#3 Updated by Giovanni Manghi about 6 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Category set to C++ Plugins

I am not sure it is GDAL's issue or QGIS's issue, but I hope it will be fixed as soon as possible, otherwise some potential Japanese (Korean, Chinese..) users would give up to use QGIS.

Please make your case in the developer mailing list in order to have someone review and eventually apply

https://github.com/qgis/Quantum-GIS/pull/581

#4 Updated by Minoru Akagi about 6 years ago

I want to tag this issue as blocker if possible, because with QGIS 1.6 (QGIS-OSGeo4W-1.6.0-14615-Setup.exe, which can be downloaded from download page. It is compiled against GDAL 1.7.3), georeferencing works well even if the output file path includes non-ascii characters.

#5 Updated by Giovanni Manghi about 6 years ago

  • Priority changed from Normal to Severe/Regression

Minoru Akagi wrote:

I want to tag this issue as blocker if possible, because with QGIS 1.6 (QGIS-OSGeo4W-1.6.0-14615-Setup.exe, which can be downloaded from download page. It is compiled against GDAL 1.7.3), georeferencing works well even if the output file path includes non-ascii characters.

if is a regression, is a blocker.

#6 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Pull request #581 was merged.

#7 Updated by Minoru Akagi about 6 years ago

Thank you, Giovanni and Jürgen!

#8 Updated by Giovanni Manghi about 6 years ago

Minoru Akagi wrote:

Thank you, Giovanni and Jürgen!

Thank Jürgen, I did nothing :)

Also available in: Atom PDF