Bug report #8165

gdaltools "info" does not work until you change a option

Added by Giovanni Manghi about 6 years ago. Updated about 2 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16988

Description

it returns always

Usage: gdalinfo [--help-general] [-mm] [-stats] [-hist] [-nogcp] [-nomd]
[-norat] [-noct] [-nofl] [-checksum] [-proj4] [-mdd domain]*
[-sd subdataset] datasetname

Edit: see #8165-7

57.png (651 KB) Giovanni Manghi, 2013-06-28 01:58 AM

19.png (644 KB) Giovanni Manghi, 2013-06-28 01:58 AM

24.png (629 KB) Giovanni Manghi, 2013-06-28 01:58 AM

Associated revisions

History

#1 Updated by Mathieu Pellerin - nIRV about 6 years ago

Giovanni, it works OK with me via Raster > Miscellaneous > Information on qgis master as of commit 619558d.

#2 Updated by Giovanni Manghi about 6 years ago

Mathieu Pellerin - nIRV wrote:

Giovanni, it works OK with me via Raster > Miscellaneous > Information on qgis master as of commit 619558d.

I'm on master/Linux (Ubuntu nightly builds) and does not work.

#3 Updated by Mathieu Pellerin - nIRV about 6 years ago

Ah, I did the test on a windows 7 machine, so that might be linux-specific.

#4 Updated by rcline - about 6 years ago

I get the following QString error on OS X 10.8.3 with latest nightly build from Dakaota Cartography.

An error has occured while executing Python code:

Traceback (most recent call last):
  File "/Applications/QGIS_2.0-dev.app/Contents/MacOS/../Resources/python/plugins/GdalTools/GdalTools.py", line 333, in doInfo
    d = Info( self.iface )
  File "/Applications/QGIS_2.0-dev.app/Contents/MacOS/../Resources/python/plugins/GdalTools/tools/doInfo.py", line 45, in __init__
    BasePluginWidget.__init__( self, self.iface, "gdalinfo" )
  File "/Applications/QGIS_2.0-dev.app/Contents/MacOS/../Resources/python/plugins/GdalTools/tools/widgetPluginBase.py", line 39, in __init__
    self.base = BaseDialog( iface.mainWindow(), iface, self, self.windowTitle(), commandName)
  File "/Applications/QGIS_2.0-dev.app/Contents/MacOS/../Resources/python/plugins/GdalTools/tools/dialogBase.py", line 49, in __init__
    Utils.setProcessEnvironment(self.process)
  File "/Applications/QGIS_2.0-dev.app/Contents/MacOS/../Resources/python/plugins/GdalTools/tools/GdalTools_utils.py", line 827, in setProcessEnvironment
    elif not QString( envval ).split( sep ).contains( val, Qt.CaseInsensitive ):
NameError: global name 'QString' is not defined

Python version:
2.7.2 (default, Oct 11 2012, 20:14:37) 
[GCC 4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60)]

#5 Updated by Giuseppe Sucameli about 6 years ago

  • Status changed from Open to Feedback

Unable to reproduce the Info tool's problem on my Ubuntu 12.10.

#6 Updated by Giuseppe Sucameli about 6 years ago

rcline - wrote:

I get the following QString error on OS X 10.8.3 with latest nightly build from Dakaota Cartography.

The issue you reported was fixed in edd0cdd29. Please, the next time open a new ticket.

#7 Updated by Giovanni Manghi about 6 years ago

Giuseppe Sucameli wrote:

Unable to reproduce the Info tool's problem on my Ubuntu 12.10.

as you can seen in the attached image by default there is no command in the bottom part of the dialog, but if I change one of the options then the command is filled.

#8 Updated by Giuseppe Sucameli about 6 years ago

  • Status changed from Feedback to Open
  • Subject changed from gdaltools "info" does not work anymore to gdaltools "info" does not work until you change a option

#9 Updated by Mathieu Pellerin - nIRV about 6 years ago

I see, the reason why I didn't see it is because I wasn't relying on a qgis layer, I was selecting a raster via file picker dialogue. The issue here happens when you open the gdaltool info dialogue and try to have it run on the qgis raster layer inserted by default in the input drop-down list.

In can reproduce this issue via these steps:
1. Create a new project
2. Add one raster layer
3. Open gdaltool's information window via Raster > Miscellaneous > Information...
4. The input file textbox will automatically be filed with the project's raster layer
5. Click on the 'OK' button to retrieve information on the raster layer
6. An error message box will show up

#10 Updated by Salvatore Larosa about 6 years ago

I am unable to reproduce. I don't see any message error using gdalinfo tool. (Linux)
so, IMHO this is not a blocker issue !

#11 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Closed

#12 Updated by Jürgen Fischer about 2 years ago

  • Description updated (diff)
  • Priority changed from Severe/Regression to Low

Also available in: Atom PDF