Bug report #8142

When deleting >1 column from a PostGIS layer one is always left over

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16970

Description

Add a PostGIS layer table of attributes, toggle editing, click on "delete columns" and select >1 columns to remove.

After saving edits one of the columns will always show again.

works ok on 1.8

Works fine on shapes, didn't tested on SL because deleting columns is not allowed (should be?).

delete_col.mp4 (2.46 MB) Giovanni Manghi, 2013-06-29 02:25 AM

Associated revisions

Revision 4a37805a
Added by Jürgen Fischer over 6 years ago

postgres provider: remove attribute in reverse order (fixes #8142)

History

#1 Updated by Paolo Cavallini over 6 years ago

  • Category set to Data Provider/PostGIS

#2 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Feedback

Always? Not reproducable here.

#3 Updated by Giovanni Manghi over 6 years ago

Jürgen Fischer wrote:

Always?

yes, see attached screencast

#4 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF