Bug report #8055

Panels disabled in the customization config are still available in the main menu

Added by Borys Jurgiel over 6 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Customisation Framework
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16896

Description

Panels disabled by the customization are not listed under right-click on the toolbar area, what is ok.
However they are still listed in the Settings->Panels (or I guess View->Panels in some OSes) submenu.

Btw. see customization-related blocker #8054


Related issues

Related to QGIS Application - Bug report #8054: Customization not available for panels and for dialogs co... Closed 2013-06-13

Associated revisions

Revision 0ee93eec
Added by Borys Jurgiel almost 3 years ago

[bugfix] Fix broken docks customization. Fixes #8055

Revision 84d2c3cc
Added by Borys Jurgiel almost 3 years ago

[bugfix] Fix broken docks customization. Fixes #8055

Revision 567abc1f
Added by Borys Jurgiel almost 3 years ago

[bugfix] Fix broken docks customization. Fixes #8055

History

#1 Updated by Borys Jurgiel over 6 years ago

It's probably still valid in master, however I can't check it because of #8054.

#2 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#3 Updated by Borys Jurgiel almost 6 years ago

Now in master they're also listed in the context menu.

#4 Updated by Harrissou Santanna over 3 years ago

  • Affected QGIS version changed from 1.8.0 to 2.14.3

actually it looks like deactivation of panels is not taken into account at all. They are still present.

#5 Updated by Borys Jurgiel almost 3 years ago

  • Status changed from Open to Closed

#6 Updated by Borys Jurgiel almost 3 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100

Fixed in 2.99 and backported to the future 2.14.10 and 2.18.2

Also available in: Atom PDF