Feature request #7967

Modeler: Output of a tool is not graphically used as the input of the next tool

Added by Filipe Dias about 7 years ago. Updated about 3 years ago.

Status:Closed
Priority:Low
Assignee:Victor Olaya
Category:Processing/Modeller
Pull Request or Patch supplied:No Resolution:invalid
Easy fix?:No Copied to github as #:16826

Description

The attached model has as input a Vector, which Dissolved (QGis dissolve) and used as input for Regular sampling Grid. I named the output of Qgis Dissolve as "Dissolved" and it is graphically shown as the output. In Regular sampling grid I selected "Dissolve.shp" as the Input but it is no graphically selected as such.

24.png (96.2 KB) Filipe Dias, 2013-06-02 02:11 AM

test_model.model (443 Bytes) Filipe Dias, 2013-06-02 02:11 AM

History

#1 Updated by Filipe Dias almost 7 years ago

  • Priority changed from Normal to High

Im raising the priority level on this one because this bug interferes with the preparation of support materials.

#2 Updated by Giovanni Manghi over 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Project changed from 78 to QGIS Application
  • Category deleted (64)
  • Affected QGIS version set to 2.4.0

#3 Updated by Giovanni Manghi over 5 years ago

  • Category set to Processing/Modeller

#4 Updated by Victor Olaya about 5 years ago

  • Status changed from Open to Feedback
  • Priority changed from High to Low

This is not a bug, it is intentional. The output element in the canvas just represents that the algorithm output is going to generate a definitive output of the model. The link is done from the output in the algorithm (you can expand the list of outputs clicking the + link in the lower part of the algorithm.

That way, i think it's not so meesy with more arrows than needed.

I put it in low priority, since we might consider this idea in the future for improving the model, but, since that will probably not happen in the short term, you can prepare your support materials safely with the current state of the modeler.

#5 Updated by Filipe Dias about 5 years ago

  • Tracker changed from Bug report to Feature request

Ok, I'm changing it to a feature request then.

#6 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No

#7 Updated by Nyall Dawson about 3 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

As Victor stated - this is by design

Also available in: Atom PDF