Bug report #7961

Add feature remain deactivated when toogle editing is on

Added by Luca Lanteri over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:16820

Description

When editing is on the "Add feature" remain deactivated. Others tool (move, node...) works fine.
It happens only with postGIS layer. Tested on Qgis 1.9-00a9a7d on windows 7


Related issues

Duplicated by QGIS Application - Bug report #8005: Unable to Add Features to PostGIS Layer in Quantum GIS 1.9 Closed 2013-06-05

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Category deleted (GUI)
  • Status changed from Open to Feedback

it works here, maybe a problem of permissions on the table?

#2 Updated by Paolo Cavallini over 7 years ago

This is not the correct behaviour anyway: if one does not have permissions, the Modify should not be activated.

#3 Updated by Luca Lanteri over 7 years ago

Also Cavallini confirms. It's not a problem of grant because it happens also with superuser. Moreover, the move and node tools work fine.

#4 Updated by Giovanni Manghi over 7 years ago

mescal72 - wrote:

Also Cavallini confirms. It's not a problem of grant because it happens also with superuser. Moreover, the move and node tools work fine.

then should be a regression, so a blocker.

#5 Updated by Jürgen Fischer over 7 years ago

Paolo Cavallini wrote:

This is not the correct behaviour anyway: if one does not have permissions, the Modify should not be activated.

"change geometry" and "add feature" are different things (ie. "INSERT" vs. "UPDATE" permission).

#6 Updated by Luca Lanteri over 7 years ago

Jürgen Fischer wrote:

Paolo Cavallini wrote:

This is not the correct behaviour anyway: if one does not have permissions, the Modify should not be activated.

"change geometry" and "add feature" are different things (ie. "INSERT" vs. "UPDATE" permission).

Right, but the same layer works fine with Qgis 1.8, so in this specific case it's not a grant problem.
Can I change the state to blocker or somebody else has to do it?

#7 Updated by Jürgen Fischer over 7 years ago

mescal72 - wrote:

"change geometry" and "add feature" are different things (ie. "INSERT" vs. "UPDATE" permission).

Right, but the same layer works fine with Qgis 1.8, so in this specific case it's not a grant problem.

What capabilities does QGIS detect (see vector layer properties, metadata tab)?

#8 Updated by Luca Lanteri over 7 years ago

Jürgen Fischer - wrote:
What capabilities does QGIS detect (see vector layer properties, metadata tab)?

From Layer properties:
Editing capabilities of this layer
Add Features, Delete Features, Change Attribute Values, Fast Access to Features at ID, Change Geometries

#9 Updated by Giovanni Manghi over 7 years ago

mescal72 - wrote:

Jürgen Fischer - wrote:
What capabilities does QGIS detect (see vector layer properties, metadata tab)?

From Layer properties:
Editing capabilities of this layer
Add Features, Delete Features, Change Attribute Values, Fast Access to Features at ID, Change Geometries

it seems it misses the

Add Attributes, Delete Attributes

capabilities

#10 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

this should be duplicated of #8005 and was fixed. Please reopen if necessary.

Also available in: Atom PDF