Bug report #7933

label item rotation in qgis composer should be improved

Added by Mathieu Pellerin - nIRV over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Low
Assignee:Nyall Dawson
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16803

Description

The current background drawing on rotated label items in the composer should be improved. Right now, the rotation applies to the text, but the background simply grows to cover a rectangular area, instead of having the background rotating along the text. I've attached a screenshot showing the issue, as well as a dummy project. There are three labels shown:
1. Simple label with no rotation showing correct background fill
2. Simple label with 45 degrees rotation showing wrong background fill
3. Label rendering HTML code relying on CSS transform to showcase what IMO should happen when labels are rotated

This ain't a blocker.

screenshot.png (59.4 KB) Mathieu Pellerin - nIRV, 2013-05-28 08:54 PM

label-rotate.qgs (4.92 KB) Mathieu Pellerin - nIRV, 2013-05-28 08:54 PM

Associated revisions

Revision 5262a4d6
Added by Nyall Dawson about 6 years ago

[FEATURE] [composer] Replace custom item rotation with QGraphicsItem rotation, support rotation for all types of composer items (fix #7933, fix #4884)

History

#1 Updated by Richard Duivenvoorde over 6 years ago

This seems to be caused by the same bug as: #8466

#2 Updated by Nyall Dawson about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF