Bug report #7921

Wrong Primary Keys when adding PostGIS Layer

Added by Florian Petry about 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16792

Description

When adding a PostGIS Layer the found primary keys of some layers are wrong.
Instead of a dropdown with actual columns of this table, a dropdown with the name of the geometry column and a seemingly arbitrary other column of another schema is shown.

After inserting the right index is used (seen in metadata).

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Open to Feedback
  • Category set to Data Provider/PostGIS

Is this a regression since 1.8 ?

#2 Updated by Jürgen Fischer about 7 years ago

Do you have anything reproducable?

#3 Updated by Florian Petry about 7 years ago

Just tried with a fresh install of 1.8: There are no primary keys found.
Where the dropdown fields are in master, there is empty space in 1.8.

I can reproduce this here with master, with my whole set of tables. I have no minimal example or something...

#4 Updated by Jürgen Fischer over 5 years ago

  • Resolution set to worksforme

closing for the lack of (useful) feedback.

#5 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF