Bug report #7905

unset keyboard shortcuts are not remembered

Added by Kai Borgolte almost 7 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16777

Description

When in keyboard shortcut dialog I delete a shortcut (german: "Keins setzen"), after QGIS restart the default setting is restored.

Associated revisions

Revision 111393e0
Added by Sebastian Dietrich over 4 years ago

respect shortcuts set to none (fixes #7905)
Shortcuts, that have been set to none by the user, are no longer restored to their default value on application startup.

Revision aedcf3a7
Added by Nyall Dawson over 4 years ago

Merge pull request #2551 from SebDieBln/RestoreEmtpyShortcuts

Do not reapply default value to shortcuts that are set to "none" (fixes #7905)

History

#1 Updated by Borys Jurgiel over 6 years ago

  • Operating System deleted (Windows)

Confirmed. Unset shortcuts are restored to default values.

#2 Updated by Sebastian Dietrich over 4 years ago

Confirmed in master (6035d98b4a2669616a0122c0c94dfbd87770164b).

Intersting though:
The Save... and Load... functions of the shortcut configuration dialog work as intended with unset shortcuts.

#3 Updated by Sebastian Dietrich over 4 years ago

See PR 2551 for a solution.

#4 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF