Bug report #7892

columns order in vector properties -> fields is wrong

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16765

Description

it seems that ordering of columns in the "Fields" tab of vector properties is not the same that the user sees when it opens the table of attributes.

Should be a regression.

46.png (342 KB) Giovanni Manghi, 2013-05-24 03:25 AM

54.png (227 KB) Giovanni Manghi, 2013-05-24 03:25 AM

59.png (225 KB) Giovanni Manghi, 2013-05-24 03:25 AM

Associated revisions

Revision dcc72d26
Added by Matthias Kuhn over 6 years ago

[Fix #7892] Fields properties: Fix sorting by id (numeric)

History

#1 Updated by Nathan Woodrow over 6 years ago

Does for me.

Does it really matter the order is different. The field tab can also be sorted.

#2 Updated by Giovanni Manghi over 6 years ago

Hi Nathan

Nathan Woodrow wrote:

Does for me.

it works for you? Here it doesn't, see attached images

Does it really matter the order is different.

as user I would expect to see the same order, it is handy especially for tables with a lot of columns.

The field tab can also be sorted.

Yes is sortable, but seems that also sorting is not working as expected, at least the the internal column is seems to be threated as text and not as number.

#3 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF