Bug report #7828

error message on startup

Added by Etienne Tourigny over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16712

Description

with latest master I get a popup message with the following error, startup continues normally after dismissing popup

Update of view in private qgis.db failed.
no such view: vw_srs

setting to GUI category, as lack of proper alternative

Associated revisions

History

#1 Updated by Nathan Woodrow over 7 years ago

Is this still and issue. Can we remove the blocker tag.

#2 Updated by Etienne Tourigny over 7 years ago

I have updated to latest master and removed my .qgis2 folder, and the issue still persists. This should be a blocker, because an error msg like this should not appear on startup and should be fixed (whatever the problem is).

#3 Updated by Etienne Tourigny over 7 years ago

  • Status changed from Open to Closed

actually, seems the problem dissapeared after running a second time, so I will close the bug.

#4 Updated by Etienne Tourigny over 7 years ago

  • Status changed from Closed to Reopened

seems it has come back... am I the only one getting this?

#5 Updated by Etienne Tourigny over 7 years ago

the following patch resolves the issue. Somehow my qgis.db was left without the vw_srs view.

diff --git a/src/app/qgisapp.cpp b/src/app/qgisapp.cpp
index 6ebb242..4b4795c 100644
--- a/src/app/qgisapp.cpp
+++ b/src/app/qgisapp.cpp
@@ -2160,7 +2160,7 @@ bool QgisApp::createDB()
     }

     if ( sqlite3_exec( db,
-                       "DROP VIEW vw_srs;" 
+                       "DROP VIEW IF EXISTS vw_srs;" 
                        "CREATE VIEW vw_srs AS" 
                        " SELECT" 
                        " a.description AS description" 

#6 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF