Bug report #7823

Vector\\Data management\\Merge shapefiles is not working correctly

Added by Maxim Dubinin over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16708

Description

Testdata: http://gis-lab.info/forum/download/file.php?id=6542

Merging goes without errors, but attributes from the second shapefile are not merged to the first, only geometries are merged.

QGIS 1.9 1fce8a3 on Win7


Related issues

Related to QGIS Application - Bug report #7708: Union produces the wrong output (plus progress bar does n... Closed 2013-04-25
Related to QGIS Application - Bug report #7707: "merge shapefiles" produces wrong output on master (ok on... Closed 2013-04-25
Related to QGIS Application - Bug report #7570: "Merge shapefiles to one" not working in Master. Closed 2013-04-11

Associated revisions

Revision 7d75fcc3
Added by Minoru Akagi over 6 years ago

fTools: fix MergeShapes and SpatialJoin
fix #7823
fix #7952
fix #8206

History

#1 Updated by vinayan Parameswaran over 6 years ago

duplicate of #7707?

#2 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

used to work ok for you on 1.8? If yes please tag this as blocker.

#3 Updated by Maxim Dubinin over 6 years ago

#7707 seems to be about geometries, my question here is about incorrect transfer of attributes.

UPD link for the tests, first one is wrong: http://gis-lab.info/forum/download/file.php?id=6557

1.8 works ok with the exception of not handling encoding correctly.

#4 Updated by Maxim Dubinin over 6 years ago

  • Priority changed from Normal to Severe/Regression

#5 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Feedback to Open

#6 Updated by Minoru Akagi over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF