Bug report #7781

Bug report #8051: setSubsetOfAttributes() doesn't work

selecting attributes in add attribute table in Map Composer not working well

Added by Alexandre Neto over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16676

Description

After adding an attribute table to composer, and deselecting some of the attributes, the resulting table show the same number of columns, but with empty cells.

In the following image, only "numero" and "estado" attribute were selected.

Working well in 1.8, therefore I think it's a regression.

Associated revisions

Revision abd7533f
Added by Jürgen Fischer about 6 years ago

composer table:
- fix api updates (fixes #7781)
- store/restore geometry of attribute selection dialog

History

#1 Updated by Carlos da Ponte over 6 years ago

Having them same issue. would be great to have a fix on this soon as personally I'm having to use the master as a production version due to the massive feature differences between it and 1.8.

thanks!
C

#2 Updated by Nathan Woodrow over 6 years ago

  • Parent task set to #8051

#3 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF