Bug report #7771

change label of "alpha channel" in color picker

Added by Regis Haubourg over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16667

Description

In composers, item background properties "transparency" and the associated slider disappeared to a more soimple color picker integrating alpha channel value.
This is good an a more simple UI. Anyway, most users don't know a word about alpha channel. We should change label of alpha channel to point the use of it:
We could turn from "alpha channel" to "transparency (alpha channel)"

Discussed here:
we got here a functionnal regression for user not aware of alpha channel. This very small change seems mandatory to me in v2.0 since new users will be lost, and since old composers

History

#1 Updated by Regis Haubourg over 6 years ago

  • Target version set to Version 2.0.0

#2 Updated by Larry Shaffer over 6 years ago

Hi Regis,

I don't think this is easily possible. When making those changes, I too worried about the potential confusion on Linux and Mac (don't remember what it's like on Win). Basically, all of the new QgsColorButtons pop up the platform's native color picker, which can not be customized to that extent without working directly with the OS's API.

As an alternative, we could use the Qt color picker (which is not that great) or make a better one in C++/Qt. Similarly, on Mac the transparency slider is inverted and labeled as Opacity.

On the good side, it is the native color picker, and user's should know how to use it. It also does not present them with yet another different color picker to learn.

So, my vote would be to leave it as is, or make (reuse) a better Qt/C++ picker.

Side note: I also tried adding a small 'badge' to the color button to signify the color picker supports an alpha channel change, but settled on only using the translucent checkerboard background. The badge would still help out when the button is opaque, though.

#3 Updated by Regis Haubourg over 6 years ago

  • Status changed from Open to Closed

Hi Larry, thanks for the explanations.
I really appreciate the uniform color picker with the "transparency" badge that does the job. I understood immediatly that transparency was set inside color picker. If modifying it is not possible, I guess I will have to teach some more things to my students ;-).
I close the ticket now to avoid noise.

Also available in: Atom PDF