Bug report #7736

data defined rotation does not work for point pattern fills

Added by aperi2007 - almost 11 years ago. Updated about 10 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16642

Description

When using a symbol pattern inside a polygon is is sometimes useful to set a rotation angle for single pattern using an angle filled from the shapefile.

Apparently it is settable, but doesn't work.

Setting the "angle" (angolo field) in data-defined-properties inside the
"Point pattern fill" -> Marker -> simple marker
should rotate using the specified value for each single polygon - instead they all have the same rotation.

I guess this is a bug, because the option to set is available.

I added a simple project to show this.

Regards,
Andrea.

rotate-project.zip - sample project (5.38 KB) aperi2007 -, 2013-04-29 01:35 PM

qgis-rotation-works.png (187 KB) Mathieu Pellerin - nIRV, 2013-05-29 03:59 AM

Associated revisions

Revision fd85aeea
Added by Jürgen Fischer over 10 years ago

consider data defined svg pattern rotation (fixes #7736)

Revision 3c5c7de3
Added by Radim Blazek about 10 years ago

Fixed point pattern fill usedAttributes(), fixes #7736

History

#1 Updated by Jürgen Fischer almost 11 years ago

  • Subject changed from qgis 1.9 don't allow a pattern rotate using data definition to qgis 1.9 doesn't allow data defined rotation of pattern

#2 Updated by Giovanni Manghi almost 11 years ago

  • Priority changed from Normal to Severe/Regression

this is a new feature not working as it should be, so I guess is a blocker.

#3 Updated by Marco Hugentobler almost 11 years ago

  • Assignee set to Marco Hugentobler

#4 Updated by Mathieu Pellerin - nIRV over 10 years ago

Using an integer and real field to set rotation for individual marker in a points layer works fine. I've just confirmed with latest build (see screenshot). Maybe the person who filed this issue can re-open with more steps to reproduce if he/she still faces this problem.

#5 Updated by aperi2007 - over 10 years ago

  • Resolution deleted (worksforme)

The ticket is for a polygonal layer not for a puntual layer.

I try it with the last qgis-dev,

but the option of the angle in data-defined is disappeared.

This is a more complex situaztion.

I'm sure this is not working, but not because the angle option was removed it is no more selectable. :)

#6 Updated by Giovanni Manghi over 10 years ago

  • Status changed from Closed to In Progress

#7 Updated by Giovanni Manghi over 10 years ago

  • Status changed from In Progress to Open

#8 Updated by Mathieu Pellerin - nIRV over 10 years ago

Right. More testing on this:
- using simple marker as point pattern fill, data-defined rotation fails when relying on an attribute
- it'll however succeed if you use an expression with a fixed number, e.g. '45'
- same behavior for svg marker within point pattern fill

Note that this isn't a regression as qgis 1.8's point pattern fill didn't have the data-definition feature and the old symbology didn't have point pattern fill.

#9 Updated by Nathan Woodrow over 10 years ago

I'm not sure this should be blocker as there is still some missing features from the data defined but we should just aim for 2.1 for those.

#10 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Open to Closed

#11 Updated by Giovanni Manghi over 10 years ago

  • Subject changed from qgis 1.9 doesn't allow data defined rotation of pattern to data defined rotation does not work for point pattern fills
  • Status changed from Closed to Reopened
  • Target version changed from Version 2.0.0 to Future Release - High Priority

it works for centroid fills and svg fills. Affects 2.0 and master.

#12 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Reopened to Closed

#13 Updated by Giovanni Manghi over 10 years ago

  • Status changed from Closed to Reopened

#14 Updated by Radim Blazek about 10 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF