Bug report #7713

qgis mapserver on Windows does not accept "\\" in project paths

Added by Giovanni Manghi over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16624

Description

the url

http://localhost/cgi-bin/qgis_mapserv.fcgi?map=c:/temp/teste18.qgs

works, while

http://localhost/cgi-bin/qgis_mapserv.fcgi?map=c:\\temp\\teste18.qgs

does not. The error message is

"(No error code was reported) The WMS vendor also reported:
Configuration file problem : perhaps you left off the .qgs extension?"

and to make it work it is necessary to select the checkboxes "Ignore
GetMap... and Ignore GetFeatureInfo... ".

Is this the correct behavior?

History

#1 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#2 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I guess it is by design.

Also available in: Atom PDF