Bug report #7709

zoom to full is wrong if in the project there is a CSV file or a geometryless postgis table

Added by Giovanni Manghi over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16620

Description

happens on master, works fine on 1.8

Associated revisions

Revision b9fc239e
Added by Nathan Woodrow about 6 years ago

Don't inlude empty extents in full extents. Fix #7709

History

#1 Updated by Chris Crook over 6 years ago

Hi Giovanni

Do you mean CSV file using delimited text provider? Or CSV with OGR provider? I haven't been able to replicated with a delimited text provider, and it has had a few fixes since then. Is the problem still there for you, and can you provide steps to replicate?

Thanks
Chris

#2 Updated by Giovanni Manghi over 6 years ago

Chris Crook wrote:

Hi Giovanni

Do you mean CSV file using delimited text provider? Or CSV with OGR provider? I haven't been able to replicated with a delimited text provider, and it has had a few fixes since then. Is the problem still there for you, and can you provide steps to replicate?

Thanks
Chris

Hi Chris,

I just tested master and still see it.

The table is added with OGR, and you must test with the "zoom full" in the navigation toolbar, not with "zoom to layer extent" in the vector dialog.

It is seems to happen only if the project is a projected CRS, not when in a geographic one.

#3 Updated by Paolo Cavallini about 6 years ago

  • Category set to GUI

#4 Updated by Giovanni Manghi about 6 years ago

  • Subject changed from zoom to full is wrong if in the project there is a CSV file to zoom to full is wrong if in the project there is a CSV file or a geometryless postgis table

it happens also when adding a geometryless postgis table

#5 Updated by Anonymous about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF