Bug report #7684

Labeling not working with field containing non-alphabetic characters

Added by Leyan Ouyang over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16601

Description

If a field name contains a space or another non-alphabetic character, it is impossible to choose this field for labeling. However, when choosing it from the expression builder, it works, because it is enclosed in quotes.

I proposed a small patch to enclose the field names in quote when they contain any character other than [a-zA-Z] : https://github.com/qgis/Quantum-GIS/pull/552

History

#1 Updated by Giovanni Manghi over 6 years ago

weird, the patch has not been applied but I can't replicate the issue, at least with shapes created within qgis with spaces and chars like "ã" in column names.

#2 Updated by Leyan Ouyang over 6 years ago

  • Status changed from Open to Closed

Hum, that's weird, I don't know what I did, today I can't reproduce the problem when simply selecting a field. However there is still a problem when first selecting a field then choosing to build an expression, the field is not given quotes.

Anyway, this is pretty minor and not exactly the same thing. I will just make a small patch for that.

Also available in: Atom PDF