Bug report #7658

Creating/exporting raster crashes application

Added by Nathanael Boehm over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Radim Blazek
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16578

Description

I want to rasterize vector contour lines for relief shading but QGIS 1.9 keeps crashing on me whenever I touch the rasters.

Steps:

  1. Open or create new GRASS mapset
  2. Use v.in.ogr to import vector (see attached sample vector from Geoscience Australia) w/ default (no advanced settings)
  3. Use v.to.rast.attr with ELEVATION as z index
  4. It appears to run, but crashes
  5. When I restart QGIS, I can add the newly created GRASS raster layer but I can't see anything on the canvas
  6. Attempting anything with the raster (including just toggling visibility, or outputting as a GeoTIFF) crashes QGIS again

Sample_Contours_line.zip (161 KB) Nathanael Boehm, 2013-04-19 11:23 PM

History

#1 Updated by Nathanael Boehm over 6 years ago

There is nothing useless in the trace "Faulting application qgis-dev.exe, version 0.0.0.0, faulting module unknown, version 0.0.0.0, fault address 0x0000ffff"

#2 Updated by Werner Macho over 6 years ago

confirmed on current master 257ee9c004f on self compiled QGIS
Linux Debian

#3 Updated by Giovanni Manghi over 6 years ago

  • Operating System deleted (Windows XP SP3)
  • Target version set to Version 2.0.0
  • Priority changed from Normal to Severe/Regression
  • Category changed from GRASS to Rasters

confirmed here also with tools that are not grass

#4 Updated by Nyall Dawson over 6 years ago

Possibly related are #7608 and #7624.

#5 Updated by Nyall Dawson over 6 years ago

Also #7659

#6 Updated by Radim Blazek over 6 years ago

  • Assignee set to Radim Blazek

#7 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Feedback

Works for me on Debian with GRASS 6.4.2.

  1. Use v.in.ogr to import vector (see attached sample vector from Geoscience Australia) w/ default (no advanced settings)
  2. Use v.to.rast.attr with ELEVATION as z index
  3. It appears to run, but crashes

What does crash and when? v.to.rast or QGIS? When you run the module or when you try to display the result? Does it work if you run the same in GRASS shell? Can you display the result in GRASS monitor by d.rast?

  1. When I restart QGIS, I can add the newly created GRASS raster layer but I can't see anything on the canvas
  2. Attempting anything with the raster (including just toggling visibility, or outputting as a GeoTIFF) crashes QGIS again

Various raster bugs were recently fixed, please try if the problem persists.

#8 Updated by Nathanael Boehm over 6 years ago

Thanks yes I know I've since managed to successfully create a raster through GRASS so I would have to go back and find the exact files I was working on to see if I can reproduce in the current build.

#9 Updated by Radim Blazek over 6 years ago

  • Status changed from Feedback to Closed

Seems to be fixed, reopen if necessary.

Also available in: Atom PDF