Bug report #7654

Python Console editor unable to import qgis.*

Added by Gary Sherman over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System:OS X, Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16574

Description

The Python Console editor (d4d26257b77) is unable to import qgis and other modules when running a script. See attached screen shot. The console is able to import.

This occurs even if the PYTHONPATH points to the qgis modules prior to running QGIS.

CoRDScreenSnapz005.png (70.1 KB) Gary Sherman, 2013-04-19 09:58 AM

History

#1 Updated by Salvatore Larosa over 7 years ago

  • Status changed from Open to Feedback

Hi Gary,

Did you have set the PYTHONPATH in Settings -> System ?

Maybe it is better to warn the user with any message!
However, I will try to fix it in a different way.

Thanks for the feedback!

#2 Updated by Nathan Woodrow over 7 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Seems to be fixed now

Also available in: Atom PDF