Bug report #7618

Distance Matrix entries are only calculated for the first feature

Added by Anita Graser over 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16543

Description

To reproduce, you can simple use the airport.shp dataset from the QGIS sample data. Try to calculate distance matrix. The resulting distance matrix text file only contains entries for the first feature.

I've attached a screenshot too.

This tool used to work correctly in 1.8, so this is a regression.

distmatrix.png (232 KB) Anita Graser, 2013-04-15 10:01 AM

Associated revisions

Revision 345a0aef
Added by vinayan Parameswaran over 6 years ago

Merge pull request #556 from vinayan/splitVector

[Fix #7618] - split vector layer does not work in master

Revision 7f522f92
Added by Alexander Bruy over 5 years ago

[processing] fix Distance Matrix tool (fix #7618)

History

#1 Updated by vinayan Parameswaran over 6 years ago

  • Pull Request or Patch supplied changed from No to Yes

submitted a pull request for this issue

https://github.com/qgis/Quantum-GIS/pull/538

#2 Updated by vinayan Parameswaran over 6 years ago

  • Status changed from Open to Closed

#3 Updated by vinayan Parameswaran over 6 years ago

  • Status changed from Closed to Reopened

wrong fix number caused auto close of this bug..sorry

#4 Updated by vinayan Parameswaran over 6 years ago

  • Status changed from Reopened to Feedback

This issue is fixed thanks to the 'iterator bug' fix by Nathan

#5 Updated by Mathieu Pellerin - nIRV over 6 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

#6 Updated by Anita Graser over 5 years ago

  • Assignee set to vinayan Parameswaran
  • Resolution deleted (fixed)
  • Target version changed from Version 2.0.0 to Future Release - High Priority
  • Priority changed from Severe/Regression to High
  • Status changed from Closed to Reopened

The issue is back in nightly. Only the distances from the first point to all other points are calculated.
Additionally, when the script is finished, one point gets selected. So if you rerun the script without noticing, the result will then only have one line (because only selected points are used by processing).

#7 Updated by Alexander Bruy over 5 years ago

Just tested fTools and all works fine. Seems this issue only in Processing

#8 Updated by Anita Graser over 5 years ago

  • Category changed from 44 to 94
  • Assignee changed from vinayan Parameswaran to Victor Olaya

#9 Updated by Alexander Bruy over 5 years ago

  • Status changed from Reopened to Closed

#10 Updated by Giovanni Manghi over 4 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF