Bug report #7607

Crash after importing a vector layer to db using DBManager

Added by Emilio Loi over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Giuseppe Sucameli
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:16535

Description

In a new project, load a shape file then import the layer to db using DBManager. After importing, close DBManager and right or left click anywhere on the canvas or on the table of content. Qgis will crash immediately.

History

#1 Updated by Giuseppe Sucameli over 7 years ago

  • Status changed from Open to Feedback
  • Assignee set to Giuseppe Sucameli

Unable to reproduce it...
Please, give me more details on how to reproduce it, OS and QGis version...

#2 Updated by Emilio Loi over 7 years ago

Giuseppe Sucameli wrote:

Please, give me more details on how to reproduce it, OS and QGis version...

It happens on Ubuntu 12.10 3.5.0-27 with Qgis versions 1.9.0-master rev 8e11e5f & rev 8694c19

#3 Updated by Giuseppe Sucameli over 7 years ago

Are you importing the shapefile on a PG or SL database? What version of PG/SL? Could you provide the shapefile (or, better, a subset) you import to reproduce the problem?

#4 Updated by Emilio Loi over 7 years ago

PostgreSQL 9.1.9
POSTGIS="2.0.2 r10789"

You can use any sample file in tests/testdata folder (i.e. french_parts.shp)

#5 Updated by Paolo Cavallini over 7 years ago

  • Priority changed from High to Normal

I cannot reproduce it either

#6 Updated by Giovanni Manghi over 6 years ago

closing for lack of feedback.

#7 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Also available in: Atom PDF