Bug report #7604

Joining KML to CSV results in NULL values

Added by Nyall Dawson over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16533

Description

Attempting to join the attached KML file ("Ingress-IPf-Level-A-T0404.kml") to the CSV file "ingress_all.csv", using the "Name" field in both layers as a join fails. The columns from the csv are added to the kml layer, but all fields are NULL.

join_data.zip (148 KB) Nyall Dawson, 2013-04-14 02:23 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

Does it works on 1.8 ?

#2 Updated by Nyall Dawson over 7 years ago

Yes -- the join works correctly in 1.8.

#3 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from Normal to Severe/Regression

#4 Updated by Minoru Akagi over 7 years ago

Seems to be fixed with commit 47fa53e

#5 Updated by Nyall Dawson over 7 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Great -- I can confirm this fix.

Also available in: Atom PDF