Bug report #7532

Startup forces new project document, even when opening data file

Added by William Kyngesburye over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16476

Description

If I double-click a data file, like a shapefile, when QGIS is not running, QGIS starts, the shapefile is added to the default new project, then QGIS tries to create a new empty project, which then causes QGIS to prompt to save the one just created with the shapefile. If I save or don't save it, a new empty project is created, without the shapefile. If I cancel, it does not create a new empty project, leaving the shapefile in the first new project. This is a regression, I think this has happened in the past, possibly Mac-specific, like something got out of sequence in the startup process when changes were made to the startup.

What should happen is that the shapefile or other data file starts QGIS and is added to a new project document. That's it, no attempt to then create another new empty project.

qgisapp_open-at-launch_patch.diff Magnifier (1.65 KB) Larry Shaffer, 2013-04-07 01:34 AM

Associated revisions

Revision 5e39bac1
Added by Larry Shaffer over 7 years ago

Fix #7532, startup forces new project document, even when opening data file

History

#1 Updated by Larry Shaffer over 7 years ago

Hi William,

Please test if attached patch fixes it. Patch works for me under 10.7.5.

#2 Updated by William Kyngesburye over 7 years ago

The patch works for me. Also 10.7.5 (and Qt 4.8.4).

#3 Updated by Larry Shaffer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF