Bug report #7452

Column values disappear when choosing an edit widget

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16411

Description

Open a shape and set a widget (tested "calendar") for a (non empty) text column. Open the table of attributes, the column is empty.

History

#1 Updated by Nathan Woodrow over 6 years ago

Can you add some more details for this.

#2 Updated by Giovanni Manghi over 6 years ago

Nathan Woodrow wrote:

Can you add some more details for this.

Hi Nathan,

I can't add much more. Just pick a vector, set the calendar widget for a text column, and then open the table of attributes. The column will show empty.

Cheers!

#3 Updated by Nathan Woodrow over 6 years ago

Just tested. If you use a calendar on non date style data then you will get blank records. Not sure what else you can expect as the attribute editor is trying to convert the string to date and it doesn't work so just returns nothing.

The other widget types work for me.

#4 Updated by Giovanni Manghi over 6 years ago

Nathan Woodrow wrote:

Just tested. If you use a calendar on non date style data then you will get blank records. Not sure what else you can expect as the attribute editor is trying to convert the string to date and it doesn't work so just returns nothing.

The other widget types work for me.

Ok, then it works in a different way from 1.8. That's ok. I guess you can close this.

#5 Updated by Nathan Woodrow over 6 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

#6 Updated by Giovanni Manghi over 6 years ago

just one doubt, this would mean that 1.8 projects that had a calendar widget associated to a text column will result in a empty column when opening on 2.0?

Also available in: Atom PDF