Bug report #7426

delete layer doesn't really delete it

Added by John Sankey over 7 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.2.0 Regression?:No
Operating System:Mac OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16388

Description

When a layer is deleted, it remains in the project somehow and slows down loading. When I had 30 layers in a project and it was taking almost a minute to load, I tried copying the project then deleting half the layers from each. It took just as long for each to load after half the layers were deleted as before. When I recreated one project with only the desired layers, it reduced storage from 147 Kb to 111 Kb and loaded almost immediately.

hcco.qgs (106 KB) John Sankey, 2013-03-27 08:45 AM

oldhcco.qgs (141 KB) John Sankey, 2013-03-27 08:45 AM

test.qgs (60 KB) paolo prosperi, 2014-07-13 07:32 AM

lcp6.png (210 KB) Giovanni Manghi, 2014-07-13 12:03 PM


Related issues

Duplicates QGIS Application - Bug report #7086: QGS file keeps trace even of deleted layers Closed 2013-02-01

History

#1 Updated by Matthias Kuhn over 7 years ago

  • Status changed from Open to Feedback

What version are you using?

Would it be possible to attach the affected project files?

#2 Updated by John Sankey over 7 years ago

Here they are

#3 Updated by Jürgen Fischer about 7 years ago

  • Status changed from Feedback to Open

#4 Updated by Daniel Vaz about 7 years ago

I can't reproduce it. I am using QGis master on Ubuntu 13.04

#5 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Open to Closed

Duplicate of #7426, closing this because the other has sample data attached.

#6 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to worksforme

Does not seems to happen on qgis master, please reopen if necessary.

#7 Updated by paolo prosperi about 6 years ago

  • File test.qgs added
  • Status changed from Closed to Reopened

Please reopen this bug as issues still occur as previously reported (see also by my original bug report #7086).
I changed computer and QGIS version (now running QGIS Valmiera 2.2 on a Windows 8.1 64bits laptop) but still have the same problems described above.
In the project file I'm attaching, the project is made of only one point vector "cities", which displays without problems. However, many other "invisible" layers are present in the .qgs file and also listes by selecting Project/Project properties/Vector information from within QGIS.

PS
Deleting the "cities" layer results in QGIS crashing.

#8 Updated by Jürgen Fischer about 6 years ago

paolo prosperi wrote:

Please reopen this bug as issues still occur as previously reported (see also by my original bug report #7086).

Can you reproduce the problem with a fresh project (ideally on 2.4 or master)?

PS: Deleting the "cities" layer results in QGIS crashing.

Might be #9779.

#9 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Reopened to Feedback

#10 Updated by Giovanni Manghi about 6 years ago

In the project file I'm attaching, the project is made of only one point vector "cities", which displays without problems. However, many other "invisible" layers are present in the .qgs file and also listes by selecting Project/Project properties/Vector information from within QGIS.

see attached images: opening the project in qgis 2.4 the layers are not "invisible", in fact qgis asks for them (including "cities" that you haven't attached here).

#11 Updated by Jürgen Fischer about 6 years ago

Giovanni Manghi wrote:

In the project file I'm attaching, the project is made of only one point vector "cities", which displays without problems. However, many other "invisible" layers are present in the .qgs file and also listes by selecting Project/Project properties/Vector information from within QGIS.

see attached images: opening the project in qgis 2.4 the layers are not "invisible", in fact qgis asks for them (including "cities" that you haven't attached here).

You just notice, because the layer data is not available. They are only in <projectlayers>, but not in the <legend> - so they wouldn't show, if the project was loaded flawlessly.

#12 Updated by Giovanni Manghi about 6 years ago

  • Resolution deleted (worksforme)
  • Affected QGIS version changed from 1.8.0 to 2.2.0

#13 Updated by Jürgen Fischer about 6 years ago

Jürgen Fischer wrote:

paolo prosperi wrote:

Please reopen this bug as issues still occur as previously reported (see also by my original bug report #7086).

Can you reproduce the problem with a fresh project (ideally on 2.4 or master)?

The question still is what removes a layer from the legend without removing it from projectlayers.

#14 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for the lack of feedback.

#15 Updated by Jürgen Fischer almost 6 years ago

  • Category set to Project Loading/Saving

Also available in: Atom PDF