Bug report #7400

Add Ring Feature Fails on Mapped Feature using Poly Tool within QGIS

Added by Jeremy Taylor over 6 years ago. Updated about 4 years ago.

Status:Closed
Priority:Low
Assignee:Nyall Dawson
Category:Vectors
Affected QGIS version:1.8.0 Regression?:No
Operating System:Lisboa Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16369

Description

I have seen this error a few times. If you map some polygons within QGIS sometimes the add ring tool does not work.
I tried a few things to fix it. Checking the geometry validity, simplifing the polygon, saving out the selection to a new shapefile. All of these failed.
One fix, was to create a brand new shapefile and copy the poly into the new shapefile. Then the add ring tool would work again.

I have the corrupt shapefile attached. If someone can look into what happened to the shapefile and find the link how it was caused by qgis that would be great.

Error.zip (3.32 KB) Jeremy Taylor, 2013-03-19 11:30 PM

Associated revisions

Revision 957d8269
Added by Nyall Dawson about 4 years ago

When adding ring to a geometry, add z or m dimensions to the
ring geometry if required (fix #7400, #7401)

History

#1 Updated by Nyall Dawson about 4 years ago

  • Assignee set to Nyall Dawson

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF