Bug report #739

GRASS Shell non-functional in OS X

Added by John Tull about 12 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Tom Elwertowski
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10798

Description

The GRASS Shell impementation in OS X is non-functional. Oddly, trying to type in commands results in keyboard shortcuts being executed for qgis. For instance, trying to type v.in.ogr stops as soon as the v key is hit. The add vector layer dialog comes up.

I do not know if this is a qgis or qt problem. Perhaps there is a method to turn off keyboard shortcuts? If so, I would recommend having them off by default, or at least requiring some form of modifier like the option key.

This happens in 0.8.1 and 0.9.

Associated revisions

Revision dc947aea
Added by William Kyngesburye about 10 years ago

don't use plain keys for shortcuts - against common UI guidelines (OSX at least), and registers while in GRASS shell (fix #739)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision f269da46
Added by William Kyngesburye about 10 years ago

don't use plain keys for shortcuts - against common UI guidelines (OSX at least), and registers while in GRASS shell (fix #739)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by John Tull about 12 years ago

Updated to reflect this issued effects v. 0.9.

#2 Updated by John Tull about 12 years ago

I tested the functionality of the GRASS shell with single-key shortcuts edited out of qgisapp.cpp (i.e., commented out "V", "N", ".", etc.) on OS X with the 0.9 source. Unfortunately, it is not so simple. The shell itself does not handle keyboard inputs properly, and there are also drawing/refresh problems (e.g., cursor disappears after sending a return keystroke).

I am changing this to a plugin defect rather than a gui defect.

#3 Updated by Tim Sutton almost 12 years ago

Hi

For me on OSX building QGIS 0.9.1trunk clicking the grass shell in the tool box does not open any GRASS shell at all.

(Sorry to take so lng to respond to your email John)

Regards

Tim

#4 Updated by Tom Elwertowski almost 12 years ago

Observations:
The initial shell prompt does not appear.
The shell subprocess dies at the first keystroke and the plugin doesn't notice.
Action keys are processed be qgis because the shell subprocess is no longer there.

The connectivity between the shell subprocess and the plugin probably needs some Mac customization. More investigation is needed.

#5 Updated by Tom Elwertowski almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed by c38a9c22 (SVN r7708).

#6 Updated by John Tull over 10 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

The new grass plugin has caused this problem to return. Same behavior as before.

#7 Updated by John Tull over 10 years ago

The new ability to change keyboard shortcuts provides a workaround to this problem. I would suggest that the defaults for OS X should be changed to meta+Letter, e.g., meta+v for add vector layer. Otherwise, we need to come up with a proper solution or this will create many problems for OS X users.

#8 Updated by William Kyngesburye about 10 years ago

Currently in Qgis 1.1.0 for me, when the GRASS shell is active, shortcuts are ignored. Though the menu still hilites briefly, which is distracting.

I would suggest, as John does, to not use plain keystrokes as shortcuts. This goes against OSX conventions (and guidelines?), and possibly Windows and Linux conventions as well. Since there appears to be some overlap in shortcuts vs. some that use platform standards or other meta keys (cmd-P for print, P for Properties), other modifier keys could also be used in combination with the platform meta (cmd-shift-P).

#9 Updated by Paolo Cavallini about 10 years ago

I would suggest to change the shortcuts and close this bug. Please OSXers check this out

#10 Updated by William Kyngesburye about 10 years ago

Are you saying change shortcuts to use meta keys for all systems (it would be good to be consistent across platforms), or create a special case set of shortcuts for OSX?

Either way, I don't know how/where to do this.

#11 Updated by William Kyngesburye about 10 years ago

OK, I found where the shortcuts are initially set in qgisapp.cpp.

I checked all the single-letter shortcuts and all but one can be changed to meta+shift+letter without conflicts. Layer->Show all layers would conflict with Save As. ...hmm, maybe U for unhide.

I'll do this later, if I don't hear any better suggestions.

#12 Updated by William Kyngesburye about 10 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Applied in f269da46 (SVN r11390).

There was also an anomaly with the + and - keys (used in zoom in/out and add/remove all from overview). + only registers with shift=, so there is no distinction between ctrl+ and shift-ctrl+. So I removed the ctrl +/- shortcuts from the add/remove all from overview actions and used ctrl +/- for zooming.

Also available in: Atom PDF