Bug report #7354

Export/Add geometry columns doesn't work as expected

Added by Salvatore Larosa over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16331

Description

The geometry columns are not create on the original layer. unless you choose an output file!

Associated revisions

Revision 1294190e
Added by Alexander Bruy over 7 years ago

fix Export geometry info tool (fix #7354)

History

#1 Updated by Alexander Bruy over 7 years ago

  • Status changed from Open to Closed

#2 Updated by Alexander Bruy over 7 years ago

  • Resolution set to fixed

#3 Updated by Salvatore Larosa over 7 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Reopened

Hi Alex,
I still cannot get it working !

#4 Updated by vinayan Parameswaran over 7 years ago

It is creating the geometry columns. But the attribute table is not refreshed. When I remove and add the same layer once again, I can see the columns

#5 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Reopened to Closed
  • Resolution set to fixed

I would propose to close this, because the tools works, it is just the table that is not refreshed. This issue affects also other tools, so is a more general one and would deserve a feature ticket (like "add a reload button in table of attributes"). If you don't agree please reopen this ticket.

#6 Updated by Salvatore Larosa over 7 years ago

Giovanni Manghi wrote:

I would propose to close this, because the tools works, it is just the table that is not refreshed. This issue affects also other tools, so is a more general one and would deserve a feature ticket (like "add a reload button in table of attributes"). If you don't agree please reopen this ticket.

Now (in 0878fca) it works as in 1.8, the fields map are refreshed. Which other tools are you refering to ?

#7 Updated by Giovanni Manghi over 7 years ago

Salvatore Larosa wrote:

Which other tools are you refering to ?

I can't remember now, but may be this patch fixed them too :) Let see if in the future we are able to spot this issue again in other tools, hopefully not.

#8 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF