Bug report #7332

The dialog (feature form) to enter attributes after having digitized a feature do not work anymore

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16317

Description

The fields are all disabled. After giving the "ok" data can be edited in the table of attributes.

Associated revisions

Revision 07c11a00
Added by Nathan Woodrow over 6 years ago

Merge pull request #467 from 3nids/immutablefields

[fix #7332] enables fields edition for newly added layers

History

#1 Updated by Denis Rouzaud over 6 years ago

I can't reproduce this.

When the edit form opens, do you have only one button (ok) or two (ok, cancel)?

#2 Updated by Giovanni Manghi over 6 years ago

Denis Rouzaud wrote:

I can't reproduce this.

When the edit form opens, do you have only one button (ok) or two (ok, cancel)?

I have two, ok and cancel. I have just tested again on two different computers, one with Windows/osgeo4w and the other with Linux/nightly-build.

#3 Updated by Salvatore Larosa over 6 years ago

I think it only happens with point layer !

#4 Updated by Giovanni Manghi over 6 years ago

Salvatore Larosa wrote:

I think it only happens with point layer !

it happens also with polygons here.

#5 Updated by Salvatore Larosa over 6 years ago

Giovanni Manghi wrote:

Salvatore Larosa wrote:

I think it only happens with point layer !

it happens also with polygons here.

You're right, but apparently only if the polygon layer has Multi* type geometries !

#6 Updated by Salvatore Larosa over 6 years ago

The geometry type was a casuality ! Sorry for the noise !

While it seems that the new checkbox "Editable"
in attribute edit dialog doesn't work as expected,
indeed the value is always unchecked, although
looking in UI file I see the property of the checkbox is "checked = True" !

This new feature has been introduced by Denis, so he could help us
to solve this issue!

#7 Updated by Denis Rouzaud over 6 years ago

I think I got the error, it probably happens only for newly created layers.
I will try to fix this tomorrow morning.

#8 Updated by Denis Rouzaud over 6 years ago

here it is
https://github.com/qgis/Quantum-GIS/pull/467

sorry for the error!

#9 Updated by Nathan Woodrow over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF