Bug report #7241

Border of vector feature visible even with no pen border

Added by gerome Bracquemont over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16269

Description

When I do not want any style border for features, the map shows white lines between objects.

See the file attached

bug_qgis.jpg (414 KB) gerome Bracquemont, 2013-02-27 05:23 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • OS version deleted (7 )
  • Operating System deleted (Windows)
  • Priority changed from High to Normal

#2 Updated by Jürgen Fischer over 4 years ago

  • Subject changed from Border on vector objet visible even with no pen border to Border of vector feature visible even with no pen border

#3 Updated by Jukka Rahkonen over 4 years ago

This tends to happen when rendering is using antialiasing. Adding a border line of the same colour as the fill often helps. Not sure if this classifies as a bug if adding borderline really helps (not tested) but it does puzzle users.

#4 Updated by Johannes Kroeger over 3 years ago

  • Status changed from Open to Closed

Duplicate of #1963

For what it's worth, the fix of adding the same color to the no-stroke border does not work for me in a satisfying way in 2.18.5.

Also available in: Atom PDF