Bug report #7140

QGIS seg faults when removing a GRASS vector (or even when "zoom to layer" or even when opening the table of attributes)

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16205

Description

Attached a simple GRASS mapset and qgis project. Try remove the vector layer from the project (or even do a "zoom to layer") and QGIS will seg fault.

teste3763.zip (43.1 KB) Giovanni Manghi, 2013-02-11 03:36 AM

Associated revisions

Revision fa348e13
Added by Radim Blazek over 6 years ago

GRASS vector crash fix #7140

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Subject changed from QGIS seg faults when removing a GRASS vector (or even when "zoom to layer") to QGIS seg faults when removing a GRASS vector (or even when "zoom to layer" or even when opening the table of attributes)

It will happen even if zooming or opening the table of attributes.

#2 Updated by Tilman Brock over 6 years ago

Can not confirm this on 1.8.0 running on windows 7 x64. Opening the project, opening the attribute table for the (only) layer named "fregue" and "Zoom to layer" works for me.

#3 Updated by Giovanni Manghi over 6 years ago

Tilman Brock wrote:

Can not confirm this on 1.8.0 running on windows 7 x64. Opening the project, opening the attribute table for the (only) layer named "fregue" and "Zoom to layer" works for me.

this is a qgis-master issue, as stated in the ticket details ("affected version").

#4 Updated by Bernd Vogelgesang over 6 years ago

can confirm this for master on Linux Mint 64bit from debian-nightly. Nearly every action with qgis with a loaded GRASS mapset leads to a crash. GRASS completely unusable!

#5 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF