Bug report #7127

Error when saving project with memory layers

Added by Larry Shaffer over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16196

Description

When saving a project with memory layers the following dialog appears:

'QgsVectorDataProvider' object has no attribute 'select'

This is since new vector api upgrade. I'm assuming this is just because the memory layer provider has not be upgraded yet.

memory-layer_on-save-error.png (11.3 KB) Larry Shaffer, 2013-02-08 07:12 PM

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from Normal to Severe/Regression

#2 Updated by Larry Shaffer over 6 years ago

  • Status changed from Open to Closed

After some more testing, it is not QGIS, but the MemoryLayerSaver plugin. Moving issue to that tracker.

Also available in: Atom PDF