Bug report #7097

QGIS keeps pinging Web services

Added by Jonathan Moules over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:16178

Description

As you can see in the attached screenshot, QGIS keeps pinging my web-services.
There are a lot of problems here:

  • QGIS can't even support WFS > 1.0.0, so I have no idea what its doing re-pinging them.
  • I have no project open. I went "new project" and discarded the previous one. So why has this been remembered?
  • The requests shouldn't be timing out in the first place - the service is still running. Typing the address into a browser URL shows it is working fine.
  • The service isn't receiving these requests.

Restarting QGIS resolves these.

Using NextGIS built against master on Windows 7, 32bit.

Clipboard03.jpg (374 KB) Jonathan Moules, 2013-02-04 08:59 AM

History

#1 Updated by Jonathan Moules over 7 years ago

Further testing - QGIS starts one of these ping cycles whenever a bad request has been made through it. So when I enter:
http://wppgeog3:8082/geoserver/wfs?SERVICE=WFS&version=1.3.0

and QGIS gives me the error message (per #7098), it then triggers this pinging. All of the ones in the screenshot brought up one or another error.

#2 Updated by Jürgen Fischer over 7 years ago

Using NextGIS built against master on Windows 7, 32bit.

Which version is that?

#3 Updated by Jürgen Fischer over 7 years ago

  • Category set to Web Services clients/WFS

#4 Updated by Jonathan Moules over 7 years ago

I don't think this is a WFS specific issue (why I didn't set that) - one of those requests is WCS.

The version I'm using is: http://gis-lab.info/programs/qgis/NextGIS-QGIS-5ed164a-29.01.2013.exe - The about page for it doesn't state what version of Master its built against.

#5 Updated by Jürgen Fischer over 7 years ago

Jonathan Moules wrote:

The version I'm using is: http://gis-lab.info/programs/qgis/NextGIS-QGIS-5ed164a-29.01.2013.exe - The about page for it doesn't state what version of Master its built against.

probably 5ed164a

#6 Updated by Jürgen Fischer about 4 years ago

  • Status changed from Open to Feedback

It this the browser querying registered web services?

#7 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF