Bug report #7068

Joined table regressions

Added by Regis Haubourg over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16152

Description

Hi all,
in master révision , I tested join table feature because many users complained in 1.8 of erratic behaviour.

JOINING a dbf table to a postgis table, i tested all Index and cache options same result.

- Displaying attribute table works
- Ordering attribute works if clicking on a field of destination table. When ordering a field of joined table, attribute table goes blank.
- Labeling or trying to create a graduated or single value analyse just don't fetch any value, and lead to crashes.

nothing works OK now, and it's probably normal with recent API merge, but we need to consolidate this before going further with 1- n relations discussed by matthias Khun and al.

thanks all
Régis

shiftedJoinedFields.zip (3.94 KB) Minoru Akagi, 2013-02-25 06:04 PM

join_blank1.png - attribute table capture (40.4 KB) Minoru Akagi, 2013-02-25 06:04 PM

Associated revisions

Revision 3959f94f
Added by Minoru Akagi over 6 years ago

Fix table join (fix #7068)

Revision 30c343cc
Added by Minoru Akagi over 6 years ago

Fix broken compatibility of table join (project file) (fix #7068)

History

#1 Updated by Minoru Akagi over 6 years ago

Added a set of test data, which includes a Shapefile and two CSV files. One CSV file (fruits1.csv) has keys for join in the first column , and the other (fruits2.csv) has them in the second. In the joined table, there is a blank field. The fields from fruits1.csv are shifted one to the left.

#2 Updated by Minoru Akagi over 6 years ago

Another test file is on #5761 (issue before the API merge). The project file in testdata.zip contains a shape layer joined with two excel sheets. On the project loading, the field joins are not fully restored. I can see only fields from "negative" layer in the attribute table. In 1.8, I can see both "positive" and "negative" fields.

#4 Updated by Mathieu Pellerin - nIRV over 6 years ago

Minoru, I've filed #7271 yesterday, and realizing your work might also cover that issue. I'll try and test things out once your patch is applied to the trunk.

#5 Updated by Denis Rouzaud over 6 years ago

I just experienced a weird effect: all my joined fields were saved in the project as layer fields...which led to non-access to edition of the layer!

#6 Updated by Anonymous over 6 years ago

  • Status changed from Open to Closed

#7 Updated by Minoru Akagi over 6 years ago

Closed automatically by the commit messages. Please reopen if problems remain.

#8 Updated by Regis Haubourg over 6 years ago

  • Status changed from Closed to Reopened

Hi,
there is no crash anymore, but still nothing working in revision 87572f7.
Styling by category, labeling of joined attributes leads to nothing displayed on map. Feature count and tests of queries in ruled based labeling works OK.
Please don't close such critical bugs without a feedback request before..
Cheers,
Régis

#9 Updated by Minoru Akagi over 6 years ago

regis Haubourg wrote:

Please don't close such critical bugs without a feedback request before..

Sorry, you are right.
Well, in master, I cannot reproduce the issues you've mentioned. Styling and labeling are working well with the attatched/linked testdata.
Could you provide any sample data that express the issues?

#10 Updated by Minoru Akagi over 6 years ago

regis Haubourg wrote:

Styling by category, labeling of joined attributes leads to nothing displayed on map.

I have been able to confirm the issue with joins of PostGIS/Spatialite layer and csv.

#11 Updated by Werner Macho over 6 years ago

manually applied the fix from PhilippeDorelon

this should now be fixed by efe3c55
please test and close this bug if everything works as expected

#12 Updated by Minoru Akagi over 6 years ago

works fine. Thank you Philippe Dorelon.
However a bug is filed to #7072 by Philippe, and there is another bug as Denis Rouzaud pointed out. See #7739.

#13 Updated by Mathieu Pellerin - nIRV over 6 years ago

Per Werner Macho's comment, who indicates a commit has fixed the issue discussed here, can we close?

#14 Updated by Regis Haubourg over 6 years ago

  • Status changed from Reopened to Closed
  • % Done changed from 0 to 100

OK to me, thanks guys.

Also available in: Atom PDF