Feature request #7057

DB Manager SQL window should remember query string when closing and re-use the string when re-opening SQL window

Added by Mathieu Pellerin - nIRV over 8 years ago. Updated over 8 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:DB Manager
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:16142

Description

Yesterday, I was working on a long SQL statement. I accidentally hit ESC on my keyboard, effectively erasing the statement.

As a way to prevent this mild "data lost", it would be nice for the DB Manager's SQL window to remember the query textbox string upon closing and re-display it upon re-opening (within the same application session).

History

#1 Updated by Paolo Cavallini over 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Rejected

duplicate of #4781

#2 Updated by Mathieu Pellerin - nIRV over 8 years ago

Paolo, it's a duplicate as long as feature #4781 includes keeping history of SQL query string that are not executed yet.

I.e., in the above case scenario, the user - clumsy me - lost the SQL query he was building up by accidentally hitting ESC. If feature #4781 only covers keeping history of executed SQL queries, scenario wouldn't be handled.

Glad the issue is being looked at. Thanks.

Also available in: Atom PDF