Bug report #7007

canvas is no more refreshed when exiting the editing mode

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16107

Description

lately in qgis master when you exit the editing mode the nodes symbols are not removed and it is needed to pan/zoom the map to have them disappear.

This happens also to newly created features that are not saved when exiting the editing mode.

It is a regression.

rollback-edits_patch.diff Magnifier (438 Bytes) Larry Shaffer, 2013-01-17 11:16 AM

Associated revisions

Revision 814d8e0e
Added by Larry Shaffer over 6 years ago

Fix #7007, canvas is not refreshing when exiting editing mode

History

#1 Updated by Larry Shaffer over 6 years ago

  • Status changed from Open to Feedback

Hi Giovanni,

I think this may be related to some work I've done, where I tried to remove all possibly redundant canvas refreshes from the toggle/save/rollback/cancel editing actions/methods.

However, I can not reproduce the issue here. Can you give a step-by-step process to repeat it? And, maybe some screen snaps?

Thanks

#2 Updated by Salvatore Larosa over 6 years ago

Confirmed here.

Steps to reproduce:

1. Open a vector file (POLYGON or LINE);
2. Any editing;
3. Close without save.

#3 Updated by Larry Shaffer over 6 years ago

Ok, I can't reproduce the issue here on Mac, but have an idea on the cause.

Try the attached patch and see if that fixes the issue. If so, it is indicative of a problem with the undo widget/canvas refresh changes I made and further testing is needed for parity of cross-platform functionality, since the patch will cause double canvas refreshes in some instances and is not the 'right' fix.

#4 Updated by Giovanni Manghi over 6 years ago

Larry Shaffer wrote:

Ok, I can't reproduce the issue here on Mac, but have an idea on the cause.

Try the attached patch and see if that fixes the issue. If so, it is indicative of a problem with the undo widget/canvas refresh changes I made and further testing is needed for parity of cross-platform functionality, since the patch will cause double canvas refreshes in some instances and is not the 'right' fix.

by the way, did you noticed this list of useless canvas redraws? #2596 ;)

#5 Updated by Salvatore Larosa over 6 years ago

Yes, the patch works for me (Linux)!

#6 Updated by Larry Shaffer over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF