Bug report #6973

SLD Description

Added by Jonathan Moules almost 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16080

Description

When exporting a style, QGIS does so with a "Description" that is basically the layer name, thus:

<se:Rule>
<se:Name>Boulders</se:Name>
<se:Description>Boulders</se:Description>
<ogc:Filter>

I believe this is invalid.
(a) It fails the GeoServer validation with error:
Element 'Description' cannot have character [children], because the type's content type is element-only

Which is consistent with:
(b) SLD spec examples show that description as:
<se:Description>
<se:Name>GS1</se:Name>
<se:Title>GeoSym</se:Title>
</se:Description>
So Description itself probably shouldn't have the description text but should contain elements.

History

#1 Updated by Giuseppe Sucameli over 8 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

It was already fixed in master branch many months ago. Unfortunately there will be no QGIS 1.8.1,so you have to wait until 2.0 is released or use the development version.

Also available in: Atom PDF